torque enhancing on Technics SL-1200/1210

yep.

Moderators: piaptk, mossboss, tragwag, Aussie0zborn, Steve E., Simon

torque enhancing on Technics SL-1200/1210

Unread postby jeantalban » Wed Jan 29, 2014 11:51 am

Hi everyone,
I intend to enhance the torque on a Technics (original model).
As described on the vinylium manual, the brown, blue, orange, resistor required is a 150Kohms.
B.U.T, contacting Mantisamusements.com to get it the so colored resistor is listed to be a 16 Kohms.
So, wich part is true from the vinylium description the color code or the ohms level ?
Would someone that did the operation could confirm one or the other?
Greetings.


here the answer of kerry from mantis :
brown blue orange is 16K ohms . . .

150K and 330K in parallel will net 100K total . . . however why not remove the resistor and put in a 100K resistor? That makes little sense to me.

The big resistor with the gray and orange band is a 1watt or maybe a ½ watt. The others are ¼ watt. What does this upgrade do?

I’d be very nervous about instructions to upgrade that had a wrong resistor value by color to start with. I’d want second opinions from people that have done the upgrade.

Having said all that I’m happy to sell you what you need if I have it . . .


Kerry Stair

Mantis Amusements
jeantalban
 
Posts: 43
Joined: Thu Jun 30, 2011 3:38 am


Re: torque enhancing on Technics SL-1200/1210

Unread postby markrob » Wed Jan 29, 2014 4:14 pm

Hi,

There does appear to be a difference between the instructions and the photo. The resistor shown in the photo is 82K (Grey Red Orange), not 16K. Perhaps the photo was an earlier version of the mod and they finally settled on 100K as the correct value. If we assume that the stated value is correct, then ignore the photo and either bridge a 150K (Brown Green Yellow) or remove R209 and replace with a 100K (Brown Black Yellow). I assume they elected to bridge the resistor because it is easier than removing the existing part (with the potential for damage of the PC board) and it allows you to easily go back to the factory value if you run into problems. It looks like the purpose of the mod is to increase the gain of the phase detector feedback. So going with the 100K value would be less feedback than the shown value in the photo (65K or 330K in parallel with 82K). BTW, I don't think there would be any danger in trying the 82K to see if that works better.

Mark
markrob
 
Posts: 1093
Joined: Wed Nov 28, 2007 2:14 am
Location: Philadelphia Area

Re: torque enhancing on Technics SL-1200/1210

Unread postby Ben » Sun Mar 22, 2015 11:33 am

How did this turned out finally??

I'm looking to do this mod on my turntable also, that would be amazing if you could do a little follow up!!

Thanks
Ben
Ben
 
Posts: 83
Joined: Sat Nov 22, 2014 12:31 pm
Location: Montreal, Canada

Re: torque enhancing on Technics SL-1200/1210

Unread postby fredbissnette » Mon Jan 23, 2017 7:42 pm

me too bumpity bump
fredbissnette
 
Posts: 199
Joined: Tue Oct 11, 2016 5:38 pm


Return to Circuits, schematics and manuals

Who is online

Users browsing this forum: No registered users and 1 guest